Getting started with
R and RStudio




GStudio@

The dashboard

The engine



A tour of RStudio
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Console

[ J [ J [ J
o - %J & - A Go to file/function i (R 01_welcome-tidyverse ~
Console  Terminal ©  Jobs - = Environment History Connections Tutorial = IS awa I I n yo u r

~/Dropbox/Teaching/Workshops/2020-gpl/01_welcome-tidyverse/ (=4 E -7 Import Dataset ~ { = list - | (&~
"} Global Environment ~ Q [ ] [ J
R version 4.0.0 (2020-04-24) -- "Arbor Day"
Copyright (C) 2020 The R Foundation for Statistical Computing
Platform: x86_64-apple-darwinl7.0@ (64-bit) Environment is empty l

R is free software and comes with ABSOLUTELY NO WARRANTY.
You are welcome to redistribute it under certain conditions.
Type ‘'license()' or 'licence()' for distribution details.

Natural language support but running in an English locale Fites | Fiots | Packages | Help | Viewer = I ype ‘ Od e h e re’

@NewFolder © Delete | =] Rename ﬁMore -
E]xching Workshops > 2020-gpl > 01_welcome-tidyverse L

Type 'contributors()' for more information and
‘citation()' on how to cite R or R packages in publications. 4 Name Size Modifiec
t. ,

R is a collaborative project with many contributors.

Type 'demo()' for some demos, 'help()' for on-line help, or [} ®] .Rhistory 95 B Jul 8,2
‘help.start()' for an HTML browser interface to help. [ @] 00_phones.Rmd 0B Jul 7, o [y
Type 'q()" to quit R. [ @] 01_getting-started.Rmd 0B Jul 7,
N I [ @] 02_data-basics.Rmd 0B Jul 7, WI ru n I
D @] 03_visualize-data.Rmd 0B Jul 7,
() @] 04_transform-data.Rmd 0B Jul 7,
[J 2] cheatsheets
() = data
[] Rl gpl-welcome-tidyverse.Rproj 2188 Jul 8,
[J @) README.Rmd 0B Jul 7,
() & slides
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o - % &=~ A Go to file/function | ~ Addins -

Console  Terminal Jobs

~/Dropbox/Teaching/Workshops/2020-gpl/01_welcome-tidyverse/

R version 4.0.0 (2020-04-24) -- "Arbor Day"
Copyright (C) 2020 The R Foundation for Statistical Computing
Platform: x86_64-apple-darwinl7.0 (64-bit)

R is free software and comes with ABSOLUTELY NO WARRANTY.
You are welcome to redistribute it under certain conditions.
Type ‘'license()' or 'licence()' for distribution details.

Natural language support but running in an English locale
R is a collaborative project with many contributors.
Type 'contributors()' for more information and

'citation()' on how to cite R or R packages in publications.

Type 'demo()' for some demos, 'help()' for on-line help, or
‘help.start()' for an HTML browser interface to help.
Type 'q()' to quit R.

|

Your turn

[ J
?\J 01_welcome-tidyverse ~ I
Environment  History Connections Tutorial —c yp e 2 + 2 I n th e
< [ | 7 Import Dataset - r's = List v | (0~

7} Global Environment ~ Q

Environment is empty

Press enter

Files Plots Packages Help Viewer -
% New Folder = @ Delete _=| Rename a More ~ @
["Jiching > Workshops > 2020-gpl > 01_welcome-tidyverse (&I

A Name Size Modifiec

.Rhistory 95 B Jul 8,2
00_phones.Rmd 0B Jul 7,
01_getting-started.Rmd 0B Jul 7,
02_data-basics.Rmd 0B Jul 7,
03_visualize-data.Rmd 0B Jul 7,

i 04_transform-data.Rmd 0B Jul 7,

(] cheatsheets

] data

t/ gpl-welcome-tidyverse.Rproj
@] README.Rmd
(] slides
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This is ephemeral though.

If you want to run this again, you'll have to type it again.

Store R code in a document instead
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Files pane

[ J
o - %J & - A Go to file/function i (R 01_welcome-tidyverse ~
Console Terminal ©~  Jobs = Environment  History Connections Tutorial =0 e es I n yo u r

~/Dropbox/Teaching/Workshops/2020-gpl/01_welcome-tidyverse/ < [ | 7 Import Dataset - { = list - | (&~
"} Global Environment ~ Q [ ]
R version 4.0.0 (2020-04-24) -- "Arbor Day"
Copyright (C) 2020 The R Foundation for Statistical Computing
Platform: x86_64-apple-darwinl7.0@ (64-bit) Environment is empty l

R is free software and comes with ABSOLUTELY NO WARRANTY. C
You are welcome to redistribute it under certain conditions. I re‘ o
Type ‘'license()' or 'licence()' for distribution details.

Natural language support but running in an English locale Files Plots Packages Help Viewer -0
R is a collaborative project with many contributors. @ New Folder | @ Delete =] Rename | {(f More ~
Type 'contributors()' for more information and (Jiching > Workshops > 2020-gpl > 01_welcome-tidyverse (&l
‘citation()' on how to cite R or R packages in publications. 4 Name Size Modifiec
t.
Type 'demo()' for some demos, 'help()' for on-line help, or [} ®] .Rhistory 95 B Jul 8,2
'help.start()' for an HTML browser interface to help. (] @] 00_phones.Rmd 0B Jul 7,
Type 'q()" to quit R. (] @] 01_getting-started.Rmd 0B Jul 7,
N I [} @] 02_data-basics.Rmd 0B Jul 7,
[} @] 03_visualize-data.Rmd 0B Jul 7,
K- 04_transform-data.Rmd 0B Jul 7,
[J 2] cheatsheets
() = data
[] Rl gpl-welcome-tidyverse.Rproj 2188 Jul 8,
[} ©] README.Rmd 0B Jul 7,
() & slides
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[+~ Op | <2 - A Go to file/function -~ Addins ~

Console  Terminal Jobs

~/Dropbox/Teaching/Workshops/2020-gpl/01_welcome-tidyverse/

R version 4.0.0 (2020-04-24) -- "Arbor Day"
Copyright (C) 2020 The R Foundation for Statistical Computing
Platform: x86_64-apple-darwinl7.0 (64-bit)

R is free software and comes with ABSOLUTELY NO WARRANTY.
You are welcome to redistribute it under certain conditions.
Type ‘'license()' or 'licence()' for distribution details.

Natural language support but running in an English locale
R is a collaborative project with many contributors.

Type 'contributors()' for more information and
'citation()' on how to cite R or R packages in publications.

Type 'demo()' for some demos, 'help()' for on-line help, or
‘help.start()' for an HTML browser interface to help.
Type 'q()' to quit R.

|

Your turn

?5] 01_welcome-tidyverse ~

Environment  History Connections Tutorial —c

< [ | 7 Import Dataset - r's
7} Global Environment ~ Q

Environment is empty

Find 01_getting-
started.Rmd

= list - | (&~

Files Plots Packages Help Viewer

t.

@) 00_phones.Rmd 0B
01_getting-started.Rmd 0B
02_data-basics.Rmd 0B

@] 03_visualize-data.Rmd 0B

@) 04_transform-data.Rmd 0B

(] cheatsheets

] data

t/ gpl-welcome-tidyverse.Rproj

@] README.Rmd

(] slides

©) New Folder | © Delete | =] Rename GMcrev
\:]xching Workshops > 2020-gpl > 01_welcome-tidyverse L

4 Name Size

©] Rhistory 95 B

= Click on its name to

open the file

Jul 8,2
Jul7,
Jul 7,
Jul 7,
Jul 7,
Jul 7,
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Source pane

o - % =~ (=] # Go to file/function ~ Addins ~ DOCu ments
Qj 01_getting-started.Rmd — Em
G A BC Q| g Knit - - Winsert - | &+ L | =pRun ~ | B~ | = [

B . open here
2 title: "Getting Started with R and RStudio"
3  output: html_document
4 ---
5
6~ """ {r setup} »
7 library(tidyverse)
ga
9
10 -~ ## R Markdown o
11
12 This is an [R Markdown](http://rmarkdown.rstudio.com) file (it has a .Rmd file extension). <l
When you execute code within the file, the results appear beneath the code. [
13
14 R code goes in **code chunks**, denoted by three backticks. Try executing this chunk by
1:4 E3 Getting Started with R and RStudio * B B R Markdown = §§ ()
Console Terminal © Jobs =M O
. =gTToT - " - ()
)
R is a collaborative project with many contributors. O
Type 'contributors()' for more information and @]
‘citation()' on how to cite R or R packages in publications. O
. . . , . O
Type 'demo()' for some demos, 'help()' for on-line help, or
‘help.start()' for an HTML browser interface to help. .
Type 'q()' to quit R. @)
O
>
B
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R Markdown

I e == Document format that

=
o) e S s Winsert + /L “HRun - | G~ =@
o & [ ]

title: "Getting Started with R and RStudio"

output: html_document
6~ " {r setup} »
7 library(tidyverse)
g °
: Acts like a notebook
10 - ## R Markdown

File

11
12 This is an [R Markdown](http://rmarkdown.rstudio.com) file (it has a .Rmd file extension). 4

[ ]
When you execute code within the file, the results appear beneath the code. [w
: or your analysis
14 R code goes in **code chunks**, denoted by three backticks. Try executing this
1.4 3 Getting Started with R and RStudio * ] R Markdown O

Console Terminal =  Jobs - ==l @]
~/Dropbox/Teaching/Workshops/2020-gpl/01_welcome-tidyverse/ D
= = - = O

R is a collaborative project with many contributors. O
Type ‘'contributors()’ for more information and O
‘citation()' on how to cite R or R packages in publications. O
Type ‘'demo()' for some demos, 'help()' for on-line help, or O
‘help.start()' for an HTML browser interface to help. u
Type 'q()' to quit R. @]
@)

l v
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R Markdown

==

@ 01_getting-started.Rmd

& & QU g kit - Winsert + |+ | “#Run v | ‘G ~

10§ ## R Markdown I ext
11

12§ This is an [R Markdown](http://rmarkdown.rstudio.com) file (it has a .Rmd file extension).
When you execute code within the file, the results appear beneath the code.

13

14§ R code goes in **code chunks**, denoted by three backticks. Try executing this chunk by

clicking the *Run* button (a small green triangle) within the chunk or by placing your cursor
inside it and pressing *Ctrl+Shift+Enter* (or *Cmd+Shift+Enter* on Mac).

15
16~ " {r} =z
17 ggplot(data = mpg) +
18 geom_point(mapping = aes(x = cty, y = hwy), alpha = 0.2)
19+ "
A X
L] o

L]
40-

oo

oo
oo
°

30-

hwy

o0 e

1900

® o
o eoe
oo

o
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R Markdown

==

@ 01_getting-started.Rmd

& Pl QU g kit - - Winsert + |~ | “#Run v 4

10 ~ ## R Markdown I ext
11

12 This is an [R Markdown](http://rmarkdown.rstudio.com) file (it has a .Rmd file extension).
When you execute code within the file, the results appear beneath the code.
13

14 R code goes in **code chunks**, denoted by three backticks. Try executing this chunk by

clicking the *Run* button (a small green triangle) within the chunk or by placing your cursor
inside it and pressing *Ctrl+Shift+Enter* (or *Cmd+Shift+Enter* on Mac).

15

16 " {r} >

17 §| ggplot(data = mpg) +

18 geom_point(mapping = aes(x = cty, y = hwy), alpha = 0.2)
198 "

14

°
40-
°
e o
°
°
° °
e e o
o o o o
30- e © '}
e © o @ o o
; o o e
i o o o o o
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R Markdown

@ 01_getting-started.Rmd
] & Qg kit - - Winsert v | %

Ll =®Run v | & ~
10 ~ ## R Markdown
11

12 This is an [R Markdown](http://rmarkdown.rstudio.com) file (it has a .Rmd file extension).
When you execute code within the file, the results appear beneath the code.

0
il |y

13

clicking the *Run* button (a small green triangle) within the chunk or by placing your cursor

inside it and pressing *Ctrl+Shift+Enter* (or *Cmd+Shift+Enter* on Mac).
15
16~ """ {r} >

17 ggplot(data = mpg) +
18 geom_point(mapping = aes(x = cty, y = hwy), alpha = 0.2)

14 R code goes in **code chunks**, denoted by three backticks. Try executing this chunk by

14

194+ °°°
A X
o | Out ut
°
40-
°
e o
°
°
° °
L] L] o
o o o
30- ® © o
E\ e o e o
e o o
< o o o e
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Your turn

@] 01_getting-started.Rmd

[ ] [ ]
RS -xxx Read the instructions
10 ~ ## R Markdown
11
12

This is an [R Markdown](http://rmarkdown.rstudio.com) file (it has a .Rmd file extension).
When you execute code within the file, the results appear beneath the code.

13

14 R code goes in **code chunks**, denoted by three backticks. Try executing this chunk by Ru n the COd e Ch u n k by
clicking the *Run* button (a small green triangle) within the chunk or by placing your cursor

inside it and pressing *Ctrl+Shift+Enter* (or *Cmd+Shift+Enter* on Mac).
15

e = clicking the play button

18 geom_point(mapping = aes(x = cty, y = hwy), alpha = 0.2)
198 "

°
40-
°
o o
°
°
° °
e o o
o o o o
30~ e © e
e o o @ o o
; o e e
i © o o o o
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Add a new chunk

Put 2 + 2inthe chunk and run it
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Knitting

"Knit" an R Markdown document into a standalone sharable file

@ 01_getting-started.Rmd )
- &) Q@ Kknit « 0 - Y insert ~ | G L ~®Run v | B v | =
@] Knit to HTML 20 . 25 %0 %
"% Knit to PDF
- W Knit to Word
21 ~ Knit with Parameters...
zz Knit Directory g icking the *Insert Chunk* button on the
{ Clear Knitr Cache... d/Ctrl+Option+I*.
24

17/ 33



R Markdown

The best way to combine R code and narrative

We'll use it throughout the workshop:

I'll provide starter code

You'll complete "Your turns"

In the end, you'll have an annotated record for yourself
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Spot the difference:

filter(mtcars, cyl == 4)

four_cyls <- filter(mtcars, cyl == 4)

Find these chunks in the notebook and run them.

What's different about what happens?
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<- assigns the output from the righthand side to a variable with
the name on the lefthand side

four_cyls <- filter(mtcars, cyl == 4)
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List of all the

m
=]
<
=
[=]
=]
3
m
=}
-
T
%]
(=g
(=]
=
<
0
(=]
=]
=]
m
n
=t
[=]
=}
w0
_|
c
(=g
[}
=
o

il

o

w

4

N

‘D

<% |] | 7 Import Dataset ~ {

& Global Environment ~ Q variables youlve CreatEd

Data
@ four_cyls 11 obs. of 11 variables
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Find four_cy1s in the environment pane.
Click on the name four_cyls

What happens?
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@ 01_getting-started.Rmd
s % Filter

4

1
2
3
4
5
6
7
8
9

10
11

mpg
22.8
24.4
22.8
32.4
30.4
33.9
21.5
27.3
26.0
30.4
21.4

cyl

4
4
4
4
4
4
4
4
4
4

4

D four_cyls
disp hp
108.0 93
146.7 62
140.8 95
78.7 66
75.7 52
71.1 65
120.1 97
79.0 66
120.3 91
95.1 113
121.0 109

Showing 1 to 11 of 11 entries, 11 total columns

drat
3.85
3.69
3.92
4.08
4.93
4.22
3.70
4.08
4.43
3.77
4.11

wt
2.320
3.190
3.150
2.200
1.615
1.835
2.465
1.935
2.140
1.513
2.780

gsec
18.61
20.00
22.90
19.47
18.52
19.90
20.01
18.90
16.70
16.90
18.60

vs

[ R = T R e R e R e N

am

H B R 2 O R B B O O K

Q

gear

A U A WA B D BN~ B D

=0

carb

N NN R B R N B NN P

Clicking on an object in the

environment panel opens it
an interactive viewer tab
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four_cyls <- filter(mtcars, cyl == 4)

Functions do things
Functions take arguments, output results

If you want to keep the output, assign it to a variable
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To look up the help page for an R function,
type this in the console:

?function_name

(Or google it!)

25/33



Help pane

Y -y —T These help pages prove
R;i::u{: ::Iv; with matching conditions ~  Find in Topic N d e tai lS a bo u t Ith e a rgu m e n tS

you can supply a function

Return rows with matching conditions

Description Often full of examples

Use filter() to choose rows/cases where conditions are true. Unlike
base subsetting with [, rows where the condition evaluates to NA are

at the bottom

dropped.

Usage

filter(.data, ..., .preserve = FALSE)

Arguments

.data A tbl. All main verbs are S3 aenerics and onrovide methads
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Look at the help page for seq

Add a chunk that uses seq() to create a

list of numbers from 5 to 100, spaced by 5
(so 5, 10, 15, 20, ...)

02:00
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seq(from = 5, to = 100, by = 5)

##  [1] 5 10 15 20 25 30 35 40 45 50 55 60 65 70
## [20] 100
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Common syntax problem #1

Missing closing parentheses or quotes

mean (mtcars

"Oops this is wrong
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Common syntax problem #2

Surrounding somehting in quotes when it should be (or vice versa)

mean("mtcars")

## Warning in mean.default("mtcars"): argument is not numeric or
## NA

## [1] NA
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There are three chunks under "Syntax gone wrong"

Run each, read the error message, and try to fix the syntax
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Cheatsheets

Go to Help > Cheatsheets to find quick
reference guides to different packages

- v -

RStudio IDE

CHEAT SHEET

Documents and Apps

Open Shiny, R Markdown,
knitr, Sweave, LaTeX, Rd files
andmore in Source Pane

Choose  Insert
Sheing oot o ot ooke

Write Code R Support

Pro Features

ShareProject  Active shared.
with Collaborators.. collaborators.

Naigie Openinnen Save Firdand Compless fun Importdata  History ofpast  Display APres slideshows
s win replace  notcbook  selecied  withwizard  commandsto  File> New File>
code
e o e s T ===
§ 1333

rmat location _chunk e N e =a
e soion | & 2 € S0 L Comn @
T e Ty 5 - Y God Start, - 3
i 2 Re-run Sourcewithor Showfile | Load Save Deeteall  Searchinside
3 “shared users previouscode withoutEcho  outline | workspace | workspace  saved objects  environment
3 sumpto Jump Run " publish " showiiel | & " e e wihouttero - out o o d objects ‘
* previous tonet selected toserver outine : o
¢ fines 6 P yith Alt + mouse drag ot paetanionmen as st or grd
; 7 “pomsooez”
& Access markdown guide at 3 -poasoons  Codediagnostics that appear i the margin, | %2 oo ot 5 votones R
13 Help > Markdown Quick Reference 5 poaooos- __ Hover over diagnostc symbols forcetals. | oty -
i » o f
i Jumpto Setkar Runtisand Runthis n SEREEEEE | (i =
Bk dunk  alprevons  codechurk| [ o3 et aite < tmctions ¢ o fnction (3
i options e = O 4 ©) Tab completion to finish
H R el s function pames,fle paths, | Displayssaved objectsby  Viewindata  View function
i sure, crosuse) | fess n arguments, and more. ewith shortdeserption  viewer ce code
3 ptotrganey 2 rguments, yp o
H o Multanguage code [ -0
2. . R Qi it Ot e Wi
B e, Common blocksofcode. |18 s s . -
tudiorecopizes ha s named o B s
nd global .bglmg;';'ﬁ‘sm,.ynpp 2 Jymptofuncion nfile Changefiletype —
o Z siche Create | Upload Delete Rename | semmamomem Change
Voo e | 4RO Rt flreme | SAESI G,
: fun” Choose ““Blblishto e Path to displayed directory
Do e e | |6 iy v
B v e reT]  Directory minimize panes | & rten P ——
L L | Presstosee  Drag pane 4 AfFile browser keyed to your working directory.
o " command history boundaries | Clickon fleor directory nameto open.

B0 “Sares > sewons- & 6., N CUTent project
S oioum 122 CloseR
T v tmsniz,_|  Sessionin
Freses
— | PROJECT sYSTEM
:: File > New Project
| o | on Rtudio savesthe call istory,

Nameof  broect treloads eachwhen
pros you re-open a project.
Rstudio opens plots in a dedicated Plots pane

AT T — e

OpeninExport Deleta  pelete

window plot__allplots

U Package manager s everynstalled package
[rliatnglitiy

Install  Update ' Createreproducible package
Packages Packages lbrary foryour poject

Click toload package vith Paciage  Delete
library(). version  from

Debug Mode

Version Control winsiorsw

installed_lbrary

RStudio opens documentation in a dedicated Help pane

Launchdebugger  Opentaceback ooamine g Tomonat RSucioopans doene
pe bug(), browser(), @ soge Showfiie Commie  Push/Pul - view 823
debugger modew oferor G o S s oot Moty et
reme 5 ) = Homepageof  Searchwithin  Searchfor
Click next to’ Pt W Added L dm L ombn P
Clcknestto™. o0 B e - helpful in heip ile help file
add/remove a Error in get_digitCnum, ¥3.; + show Traceback | Modified fem—— Viewer Pane displays HTML content, such as Shiny apps,
breakpoint, Errort o et Doy named | Open shell to current] Markdown reports, and interactive visualizations
" e i
Highighies "; B
P Puloshingbpiio,  eesh
e Package Writing Jretred
Contas
paused File> New Project> eyl
nmmmumm W -
through  Step into and Resume  Quit debus “Tumn project into package, ——
environmentwhere  inexecuting  intracebackto (;"d; oneline auteffunctons evecuton g ® Enablerowgen documentationwith — :
execution has paused  environment debug atatime 0 run Tools > Project Options > Build Tools — 2
Roxygen guide at o » Filter rows by value Sort by Search
s e  natverane e ioraie
e StUdIO Inc.+ CCBYSA Rstudio . « Rtudio IDE 0.99.632 +

32/33



Data basics



